What's new

GUIDE UO Cartographer for UO Outlands

#1
Since UO Automap and UO Cartographer use the same marker system, I thought to make the latter work with UO Outlands too. Especially since UO Cartographer tracks your character in CUO by default. With this, all three Ultima Online mapping programs, namely UO Automap, UO Cartographer and Ultima Mapper, work with UO Outlands. Hourray!

UO Cartographer supports pan with mouse, works from start with ClassicUO client (CUO) and is easy to use. UO Automap on the other hand have way more options and show label names. I use both of them since each one have advantages and disadvantages. Everyone should judge which one is better for himself, but is always better to have more options to choose from.
J20190411_123247.png


Installation:
- Download "UO Cartographer for UO Outlands v.2019.05.01a.zip" from
https://1drv.ms/u/s!AqtI3rSJQnG_kw1XgzauBHjhzc2j and unpack it to a folder of your choice. (If you want to install it properly or need the Sosaria version, head to UOGuide and download it from there: http://www.uoguide.com/UOCartographer).

- Run UOCartographer.exe and click OK to ignore all errors. It will start with a black map. If the program is not shown on Windows taskbar after start, just use ALT+TAB to bring it to front and it will appear.

- Right-click on map and open "Options". On EC Path and CC Path enter the path where your UO Outlands is installed (example: C:\Games\Ultima Online OUTLANDS\)
Restart UO Cartographer to make sure the new path is set.


- If after restart the conversion of the maps don't start automatically, on the same Options tab, click the button from bottom-left "Rebuild".

- Restart UO Cartographer and let it rebuild the maps from Outlands folder.
UO Cartographer options.xml, the extracted maps and your personal added markers "USER.MAP", will be placed on Documents folder (c:\Users\{your windows username}\Documents\UOCartographer\).
If old Sosaria Trammel is shown up by default, just right-click on it and change the facet to Felucca. Outlands map should appear. Close UO Cartographer again to make it remember the last used facet.


* * *
If everything went fine you are all set and next step is not necessary:
Only if Outlands map won't show up or if you can't make it work, you can download this archive "UO Cartographer pre-extracted Outlands maps v.2019.05.01a.zip" and unpack it on UOCartographer folder from Documents:
https://1drv.ms/u/s!AqtI3rSJQnG_kw6qWySAaaZpJI6j
If Outlands maps will be changed at a later date, they will become obsolete and will need to be rebuilt again.
* * *


- The same markers used by UO Automap are added on UO Cartographer. The updated markers are already integrated in the ZIP file from the beginning of this post.
If/when improved markers will be released I will try to update in the same time both, UO Cartographer and UO Automap.


- Start UO Cartographer again and now it should work properly and track your character with Classic UO (CUO) and UOSteam.
 
Last edited:
#2
Last edited:
#3
Update 014 (latest version) = UO Cartographer for UO Outlands v.2019.05.01a.zip
https://1drv.ms/u/s!AqtI3rSJQnG_kw1XgzauBHjhzc2j

- Because of the map changes that came with the big patch from April 28, 2019, a map rebuilding is needed on UO Cartographer. To do this right-click on map and open "Options", then click the button from bottom-left "Rebuild". After that restart UO Cartographer and let it rebuild the maps from Outlands folder.
Only if rebuilding don't work right download the "UO Cartographer pre-extracted Outlands maps v.2019.05.01a.zip" from here:
https://1drv.ms/u/s!AqtI3rSJQnG_kw6qWySAaaZpJI6j
- Many marked locations were updated/added. For all changes made take a look here on UO Automap thread: http://forums.uooutlands.com/index.php?threads/uo-automap-for-uo-outlands.1378/post-13163

The first post of this thread was updated to the latest version.
 
#4
cartographer thinks i am in trammel facet, which has the original map. when manually switch it to felucca, it will show the outlands map but switch back to trammel (original map) as soon as i move. any idea how to fix that? thanks

edit: also, how do i enabled the advanced options, they are disabled for me.
 
#5
1. As I wrote on my original post: "If old Sosaria Trammel is shown up by default, just right-click on it and change the facet to Felucca. Outlands map should appear. Close UO Cartographer again to make it remember the last used facet."
2. UO Cartographer don't have advanced options I know of. That's why I prefer to use UO Automap.